Outage
Incident Report for WorkFlowy
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 19, 2019 - 19:48 PDT
Investigating
We're investigating the cause of a current outage.
Posted 3 months ago. Mar 19, 2019 - 19:27 PDT
This incident affected: Web App, iOS App, Android App, and Desktop App.